[经验技巧]减少源码包体积

admin 6月前 221

目前源码包已经内置了所有模块使用的composer依赖(位于vendor目录)

如果仅仅需要几个功能,这里教大家怎么使用最少的依赖


1.安装composer

【https://getcomposer.org/download/】下载并安装

使用的php环境变量必须大于php5.6,部分模块需要php7.0(如支付模块)


2.使用国内源

使用以下源【https://www.kancloud.cn/ken678/yzncms/1149002】可以更快的安装依赖


3.编辑composer.json文件

其中topthink的依赖基本为核心依赖 不建议删除  其他看各个模块的要求 如cms模块需要overtrue/pinyin:~4.0


4.命令行composer update 即可更新所有包




待更新....

最新回复 (1)
  • coolman 6月前
    0 2
    大佬,弱弱的问一下,yzncms理论上支持多大数据量的负载?
    • YznCMS交流社区
      3
        登录 注册 QQ登录
返回